[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Net::SAML build problems with 0.39



Hi all

I need Net::SAML (well something perl that does SAML anyway). But I'm
not having much luck building it. I tried 0.38 from CPAN first, but then
moved on to 0.39 from the website.

First problem is that zxpasswd doesn't build at all (this problem wasn't
there in 0.38).  When I remove zxpasswd as a dependency for all, all
seems to build fine.

But "make test" in Net/ fails with the following:

PERL_DL_NONLAZY=1 /usr/local/adapt/local/perl5.8.7/bin/perl "-Iblib/lib"
"-Iblib/arch" test.pl
Can't load 'blib/arch/auto/Net/SAML/SAML.so' for module Net::SAML:
blib/arch/auto/Net/SAML/SAML.so: undefined symbol:
zxid_idp_soap_dispatch
at /adapt/local/perl5.8.7/lib/5.8.7/i686-linux/DynaLoader.pm line 230.
 at blib/lib/Net/SAML.pm line 8
Compilation failed in require at test.pl line 5.
BEGIN failed--compilation aborted at test.pl line 5.
make: *** [test_dynamic] Error 2

And zxid.pl segfaults when run.

I tried to rerun swig, but that didn't seem to fix the problem.

I'm building on a RedHat box (RHEL 3) with perl 5.8.7, and gcc 3.2.3. 

Is this a known problem? And more importantly is there a known fix?

Borup